PHP is among the most widely used open-source web programming languages. It’s rather popular because it’s free software, which you can use to create responsive sites like community sites, shopping portals or e-teaching portals instead of static HTML-based sites. A PHP module must be available on the server where a PHP-powered website is hosted so that its source code can be ‘deciphered’. As there are no license taxes for this type of module and the language itself provides limitless possibilities for the applications that you develop, there’re 100s of millions of PHP-powered sites. Moreover, there’re an enormous number of PHP-based scripts, which you can use for your sites without needing to have any coding expertise. Considering the fact that there’re a few versions of PHP, you should confirm whether the same exact version that you used while developing your site is enabled on the server too.

PHP 4 and PHP 5 Support in Cloud Hosting

Our cloud hosting servers support different versions of PHP, which means that your websites will run faultlessly even if your PHP scripts are out of date. We realize that an old site does not always equal a vulnerable one as you may have implemented lots of code mods. That’s the reason why we support PHP 4, 5.2, 5.3, 5.4 and 5.5 and you can decide which version will be active for your hosting account. You can change the version with only one click of the mouse within your Hepsia hosting Control Panel and the update will be applied instantly. If you would like to run both newer and older scripts, there is even an option to use a different version of PHP for each of your domains at the same time.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

If you have a website built on a previous version of PHP and you’ve invested time and energy in setting it up, plugging safety gaps and publishing content, you will need a hosting service that can support it, since nearly all web hosting vendors today offer support only for the most recently introduced PHP version and remove the older versions. We, however, have decided to allow you to pick the exact version that your sites need. Our semi-dedicated servers support PHP 4 and multiple versions of PHP 5, which implies that you’ll be able to run both older and newer scripts without forfeiting any custom tweaks or misspending time and efforts struggling to make your sites compatible with the web hosting environment. The current version can be changed through the Hepsia Control Panel and such a change will apply to the entire semi-dedicated account, but you’ll also be able to pick a different PHP version for each website hosted in your account by using an .htaccess file.